Upgrade to 3.1.44

/root/.config/flexget
/root/.config/flexget/build/build/flexget
/root/.config/flexget/build/build/flexget/flexget
/usr/local/bin/flexget
/usr/local/lib/python2.7/dist-packages/FlexGet-2.10.92-py2.7.egg/flexget
/usr/local/lib/python2.7/dist-packages/flexget

I am running flexget version 2.21.35 and wanted to upgrade to the latest release: 3.1.44

I have Python 2.7 and 3.5.2 installed.

When I run: pip3 install --upgrade flexget

I get: Traceback (most recent call last):
  File "/usr/bin/pip3", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 93, in <module>
    raise RuntimeError("Python 3.5 or later is required")
RuntimeError: Python 3.5 or later is required

How can I tell pip3 to use python 3.5.2?

Flexget v3.0.0 and higher support python3.6+ only