Unable to update flexget past version 2.21.35 on Synology NAS

Hi All,

I cant seem to get my flexget updated past version 2.21.35. I have tried my best to make sure python3.x is installed. however on my synology pythong 2.7 also exists and im not sure if that is preventing the update of flexget. below is the information. would someone have some pointers for me? Thanks

`root@nas:~/.config/flexget>flexget -V
2.21.35
Latest release: 3.0.10

root@nas:~/.config/flexget>/volume1/@appstore/py3k/usr/local/bin/python3 -V
Python 3.5.1
root@nas:~/.config/flexget>which python
/bin/python
root@nas:~/.config/flexget>/bin/python -V
Python 2.7.12

root@nas:~/.config/flexget>echo $PATH
/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin:/root/.config/flexget/env/bin

root@nas:~/.config/flexget>/root/.config/flexget/env/bin/pip install --upgrade flexget
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: flexget in ./env/lib/python2.7/site-packages (2.21.35)
Requirement already satisfied, skipping upgrade: markupsafe==1.0 in ./env/lib/python2.7/site-packages (from flexget) (1.0)
Requirement already satisfied, skipping upgrade: cheroot==5.5.0 in ./env/lib/python2.7/site-packages (from flexget) (5.5.0)
Requirement already satisfied, skipping upgrade: tempora==1.8 in ./env/lib/python2.7/site-packages (from flexget) (1.8)
Requirement already satisfied, skipping upgrade: python-dateutil==2.6.1 in ./env/lib/python2.7/site-packages (from flexget) (2.6.1)
Requirement already satisfied, skipping upgrade: plumbum==1.6.3 in ./env/lib/python2.7/site-packages (from flexget) (1.6.3)
Requirement already satisfied, skipping upgrade: idna==2.5 in ./env/lib/python2.7/site-packages (from flexget) (2.5)
Requirement already satisfied, skipping upgrade: requests==2.21.0 in ./env/lib/python2.7/site-packages (from flexget) (2.21.0)
Requirement already satisfied, skipping upgrade: zipp==0.6.0 in ./env/lib/python2.7/site-packages (from flexget) (0.6.0)
Requirement already satisfied, skipping upgrade: rpyc==4.0.1 in ./env/lib/python2.7/site-packages (from flexget) (4.0.1)
Requirement already satisfied, skipping upgrade: progressbar==2.5 in ./env/lib/python2.7/site-packages (from flexget) (2.5)
Requirement already satisfied, skipping upgrade: tzlocal==1.4 in ./env/lib/python2.7/site-packages (from flexget) (1.4)
Requirement already satisfied, skipping upgrade: flask-restplus==0.10.1 in ./env/lib/python2.7/site-packages (from flexget) (0.10.1)
Requirement already satisfied, skipping upgrade: importlib-metadata==0.23 in ./env/lib/python2.7/site-packages (from flexget) (0.23)
Requirement already satisfied, skipping upgrade: webencodings==0.5.1 in ./env/lib/python2.7/site-packages (from flexget) (0.5.1)
Requirement already satisfied, skipping upgrade: flask-restful==0.3.6 in ./env/lib/python2.7/site-packages (from flexget) (0.3.6)
Requirement already satisfied, skipping upgrade: six==1.10.0 in ./env/lib/python2.7/site-packages (from flexget) (1.10.0)
Requirement already satisfied, skipping upgrade: cherrypy==10.2.2 in ./env/lib/python2.7/site-packages (from flexget) (10.2.2)
Requirement already satisfied, skipping upgrade: pyparsing==2.2.0 in ./env/lib/python2.7/site-packages (from flexget) (2.2.0)
Requirement already satisfied, skipping upgrade: sqlalchemy==1.3.3 in ./env/lib/python2.7/site-packages (from flexget) (1.3.3)
Requirement already satisfied, skipping upgrade: feedparser==5.2.1 in ./env/lib/python2.7/site-packages (from flexget) (5.2.1)
Requirement already satisfied, skipping upgrade: flask-login==0.4.0 in ./env/lib/python2.7/site-packages (from flexget) (0.4.0)
Requirement already satisfied, skipping upgrade: click==6.7 in ./env/lib/python2.7/site-packages (from flexget) (6.7)
Requirement already satisfied, skipping upgrade: zxcvbn-python==4.4.15 in ./env/lib/python2.7/site-packages (from flexget) (4.4.15)
Requirement already satisfied, skipping upgrade: babelfish==0.5.5 in ./env/lib/python2.7/site-packages (from flexget) (0.5.5)
Requirement already satisfied, skipping upgrade: apscheduler==3.5.0 in ./env/lib/python2.7/site-packages (from flexget) (3.5.0)
Requirement already satisfied, skipping upgrade: aniso8601==1.2.1 in ./env/lib/python2.7/site-packages (from flexget) (1.2.1)
Requirement already satisfied, skipping upgrade: html5lib==0.999999999 in ./env/lib/python2.7/site-packages (from flexget) (0.999999999)
Requirement already satisfied, skipping upgrade: colorclass==2.2.0 in ./env/lib/python2.7/site-packages (from flexget) (2.2.0)
Requirement already satisfied, skipping upgrade: portend==1.8 in ./env/lib/python2.7/site-packages (from flexget) (1.8)
Requirement already satisfied, skipping upgrade: pynzb==0.1.0 in ./env/lib/python2.7/site-packages (from flexget) (0.1.0)
Requirement already satisfied, skipping upgrade: path.py==11.5.0 in ./env/lib/python2.7/site-packages (from flexget) (11.5.0)
Requirement already satisfied, skipping upgrade: pytz==2017.2 in ./env/lib/python2.7/site-packages (from flexget) (2017.2)
Requirement already satisfied, skipping upgrade: certifi==2017.4.17 in ./env/lib/python2.7/site-packages (from flexget) (2017.4.17)
Requirement already satisfied, skipping upgrade: jinja2==2.10.1 in ./env/lib/python2.7/site-packages (from flexget) (2.10.1)
Requirement already satisfied, skipping upgrade: beautifulsoup4==4.6.0 in ./env/lib/python2.7/site-packages (from flexget) (4.6.0)
Requirement already satisfied, skipping upgrade: future==0.16.0 in ./env/lib/python2.7/site-packages (from flexget) (0.16.0)
Requirement already satisfied, skipping upgrade: itsdangerous==0.24 in ./env/lib/python2.7/site-packages (from flexget) (0.24)
Requirement already satisfied, skipping upgrade: chardet==3.0.3 in ./env/lib/python2.7/site-packages (from flexget) (3.0.3)
Requirement already satisfied, skipping upgrade: flask==1.0.2 in ./env/lib/python2.7/site-packages (from flexget) (1.0.2)
Requirement already satisfied, skipping upgrade: pyyaml==5.1.2 in ./env/lib/python2.7/site-packages (from flexget) (5.1.2)
Requirement already satisfied, skipping upgrade: flask-compress==1.4.0 in ./env/lib/python2.7/site-packages (from flexget) (1.4.0)
Requirement already satisfied, skipping upgrade: terminaltables==3.1.0 in ./env/lib/python2.7/site-packages (from flexget) (3.1.0)
Requirement already satisfied, skipping upgrade: guessit==3.0.3 in ./env/lib/python2.7/site-packages (from flexget) (3.0.3)
Requirement already satisfied, skipping upgrade: rebulk==0.9.0 in ./env/lib/python2.7/site-packages (from flexget) (0.9.0)
Requirement already satisfied, skipping upgrade: flask-cors==3.0.2 in ./env/lib/python2.7/site-packages (from flexget) (3.0.2)
Requirement already satisfied, skipping upgrade: werkzeug==0.15.6 in ./env/lib/python2.7/site-packages (from flexget) (0.15.6)
Requirement already satisfied, skipping upgrade: urllib3==1.24.2 in ./env/lib/python2.7/site-packages (from flexget) (1.24.2)
Requirement already satisfied, skipping upgrade: jsonschema==2.6.0 in ./env/lib/python2.7/site-packages (from flexget) (2.6.0)
Requirement already satisfied, skipping upgrade: pyrss2gen==1.1 in ./env/lib/python2.7/site-packages (from flexget) (1.1)
Requirement already satisfied, skipping upgrade: more-itertools in ./env/lib/python2.7/site-packages (from zipp==0.6.0->flexget) (5.0.0)
Requirement already satisfied, skipping upgrade: configparser>=3.5; python_version < “3” in ./env/lib/python2.7/site-packages (from importlib-metadata==0.23->flexget) (4.0.2)
Requirement already satisfied, skipping upgrade: contextlib2; python_version < “3” in ./env/lib/python2.7/site-packages (from importlib-metadata==0.23->flexget) (0.6.0.post1)
Requirement already satisfied, skipping upgrade: pathlib2; python_version == “3.4." or python_version < “3” in ./env/lib/python2.7/site-packages (from importlib-metadata==0.23->flexget) (2.3.5)
Requirement already satisfied, skipping upgrade: funcsigs; python_version == “2.7” in ./env/lib/python2.7/site-packages (from apscheduler==3.5.0->flexget) (1.0.2)
Requirement already satisfied, skipping upgrade: setuptools>=0.7 in ./env/lib/python2.7/site-packages (from apscheduler==3.5.0->flexget) (42.0.1)
Requirement already satisfied, skipping upgrade: futures; python_version == “2.7” in ./env/lib/python2.7/site-packages (from apscheduler==3.5.0->flexget) (3.3.0)
Requirement already satisfied, skipping upgrade: backports.os; python_version == “2.7” and sys_platform == “linux2” in ./env/lib/python2.7/site-packages (from path.py==11.5.0->flexget) (0.1.1)
Requirement already satisfied, skipping upgrade: functools32; python_version == “2.7” in ./env/lib/python2.7/site-packages (from jsonschema==2.6.0->flexget) (3.2.3.post2)
Requirement already satisfied, skipping upgrade: scandir; python_version < “3.5” in ./env/lib/python2.7/site-packages (from pathlib2; python_version == "3.4.
” or python_version < “3”->importlib-metadata==0.23->flexget) (1.10.0)`

You’ll need to use python 3.6 or newer starting with version 3.0.