Need help with my config (mostly the seen_movies plugin)

Hi All!

First of all, thank you for even opening this post! Seems a lot of people are struggling with the seen_movies plugin but even looking at their questions and answers i just cant seem to wrap my head around it.

First off, here’s my config:

schedules:      
  - tasks: '*'  
    interval:   
      hours: 6  
tasks:          
  import_movies_trakt:
    trakt_list:
      username: ********
      account: ********
      list: watchlist
      type: movies
    accept_all: yes
    list_add:
      - movie_list: trakt_movies

  download_movies:
    transmission:
      host: 127.0.0.1
      port: 9091
      username: *******
      password: *******
    seen_movies: strict
    list_match:
      from:
        - movie_list: trakt_movies
      single_match: no
      remove_on_match: no
      action: accept
    regexp:
      from: title
      reject:
        - korsub
    content_size:
      min: 700
      max: 15000
      strict: no
    inputs:
      - rss:
          url: https://yts.mx/rss/0/720p/all/0
          all_entries: no
      - rss:
          url: https://rarbg.to/rssdd.php?categories=48;44;45
          all_entries: no

As you can see, it’s pretty simple and I hope to keep it that way :slight_smile:
The problem is that when I run execute, the first time everything that matches my list gets ACCEPTED and it says entries are created. the movies currently in my list arent available yet so it doesn’t add them to transmission yet. (It has for movies in the past so I know it should work)

Although when I run execute directly a second time it rejects everything because it is listed in seen movies: import_movies_trakt REJECTED: ..... is already marked seen in the task import_movies_trakt at ......

How can i make sure it is not added to the seen_movie plugin db and tries to download it every time until it has?

If anyone has any other pointers to improve my config or has any good input plugins (or rss feeds) also feel free to share!

Thanks!
FlexGet newbee Gijs

Nobody? Would love some help! (and be really gratefull!)

Try adding disable: seen to your import_movies_trakt task; you don’t need to track what you have or haven’t seen there. If for some reason you do need to track what you’ve seen within that task, use seen: local.