Flexget fails after updating to V3

Previously was on 2.21.35. Decided up update to V3 today, 3.1.51. Running Ubuntu 19.10

Now when I try to execute or do anything with Flexget I receive the following errors

flexget execute
There is a FlexGet process already running for this config, sending execution there.
Traceback (most recent call last):
  File "/home/user/.local/bin/flexget", line 10, in <module>
    sys.exit(main())
  File "/home/user/.local/lib/python3.7/site-packages/flexget/__init__.py", line 41, in main
    manager.start()
  File "/home/user/.local/lib/python3.7/site-packages/flexget/manager.py", line 350, in start
    client = IPCClient(ipc_info['port'], ipc_info['password'])
  File "/home/user/.local/lib/python3.7/site-packages/flexget/ipc.py", line 192, in __init__
    channel, service=ClientService, config={'sync_request_timeout': None}
  File "/home/user/.local/lib/python3.7/site-packages/rpyc/utils/factory.py", line 44, in connect_channel
    return service._connect(channel, config)
  File "/home/user/.local/lib/python3.7/site-packages/rpyc/core/service.py", line 100, in _connect
    self.on_connect(conn)
  File "/home/user/.local/lib/python3.7/site-packages/flexget/ipc.py", line 115, in on_connect
    daemon_version = self._conn.root.version()
TypeError: 'b'instancemethod'' object is not callable

Any ideas? I’m lost here

Edit: Running “flexget --test execute” runs normally. I tried removing the database, but still the same errors

So I figured something out, but I have no idea how to fix it. I have the flexget daemon scheduled to start on reboot via Cron. If I disable that and manually start it, it works fine. Re-enable it, same errors return.

use a user systemd service to start it at boot.
make a file called flexget.service at /home/user/.config/systemd/user

here is what goes in it

[Unit]
Description=Flexget Daemon
After=network.target

[Service]
WorkingDirectory=/home/user/.config/flexget
ExecStart=/home/user/.local/bin/flexget daemon start --autoreload-config
ExecStop=/home/user/.local/bin/flexget daemon stop
ExecReload=/home/user/.local/bin/flexget daemon reload-config
Restart=on-failure
TimeoutStopSec=300

[Install]
WantedBy=default.target

then run

systemctl --user enable flexget
systemctl --user start flexget

this will keep the service running when user is not logged in (replace user with real username)
sudo loginctl enable-linger user