I'm unable to upgrade past version 2.13.14 because of this error:
discovery 0.0.4 has requirement requests==2.5.0, but you'll have requests 2.16.5 which is incompatible.
Obviously I have a newer version of requests available but apparently the discovery service relies on a specific earlier version. I've tried installing that version to have them both installed but either I'm doing it wrong or it can't find the specific version on my system.
Any help would be appreciated, Thanks.