Another noob struggling

I have been fiddling around with my flexget config.yml for days now, but I cannot seem to get it to work
(I am a noob with YAML btw).
I’ve consulted the config guide and the wiki’s.
Now the config is getting way too complex, but commenting out unnecessary parts (lists, extra filters, etc) does not seem to help getting rid of the error.

I’ve checked indentations over and over. What am i missing?

here’s the congfig.yml:

templates:
  tv:
    series:
      settings:
        identified_by: ep
        tracking: backfill
        sort_by:
          field: quality
          reverse: yes
        my group:
          quality: 720p-1080p h264 aac
      my group:
        - 'Alaska: The Last Frontier'
        - 'Alaskan Bush People'
        - 'Ash vs. Evil Dead'
        - 'Black Mirror'
        - 'Chernobyl'
        - 'Dark'
        - 'Dirk Gently s Holistic Detective Agency'
        - 'Doctor Who (2005)'
        - 'Downton Abbey'
        - 'Dual Survival'
        - 'Elementary'
        - 'Fear The Walking Dead'
        - 'Forged in Fire'
        - 'Gotham'
        - 'Grimm'
        - 'Killjoys'
        - 'Lost in Space'
        - 'Lucifer'
        - 'Mr Robot'
        - 'Philip K Dicks Electric Dreams'
        - 'Red Dwarf'
        - 'Review'
        - 'Rick and Morty'
        - 'Stan Against Evil'
        - 'Star Trek: Lower Decks'
        - 'Star Trek: Picard'
        - 'The Chilling Adventures of Sabrina'
        - 'The Mandalorian'
        - 'The Walking Dead'
        - 'The X Files'
        - 'Twin Peaks'
        - 'Westworld'
        - 'Workaholics'
        - 'Z Nation'

tasks:
  my task:
    template: tv
    discover:
      what:
        - next_series_episodes:
            from_start: yes 
            backfill: yes
      from:
        - rarbg:
            category: 41
            min_seeders: 1
            use_tvdb: yes
    max_reruns: 10

    deluge:
      host: *****
      port: *****
      username: *****
      password: *****
      path: /media/usb-drive/Partial-torrents/ 
      move_completed_path: /media/nas/Drive/tv-series/{{series_name}}/Season {{series_season}}
      queue_to_top: no

    notify:
      title: Downloading {{series_name}}
      message: Episode {{series_id}} added to queue
      via:
        - pushover:
            user_key:
              - ******************************
            api_key: ******************************
            device: mobile
            priority: 2
            sound: incoming
            retry: 60
            expire: 1000

schedules:
  - tasks: my task
      interval:
        days: 3

flexget check output:

2020-09-14 15:41:21 WARNING  check                         Config line 87 is likely missing ':' at the end
2020-09-14 15:41:21 VERBOSE  check                         Pre-checked 89 configuration lines
2020-09-14 15:41:21 CRITICAL manager                       mapping values are not allowed here in "<unicode string>", line 88, column 15: interval: ^

-------------------------------------------------------------------------------
 Malformed configuration file (check messages above). Common reasons:
-------------------------------------------------------------------------------

 o Indentation error
 o Missing : from end of the line
 o Non ASCII characters (use UTF8)
 o If text contains any of :[]{}% characters it must be single-quoted (eg. value{1} should be 'value{1}')

 Reason: mapping values are not allowed here

 ----> MOST LIKELY REASON: Missing : from end of the line!

 Check configuration near line 87, column 14

 Fault is almost always in this or previous line

2020-09-14 15:41:21 CRITICAL manager                       Failed to load config file: Config file is not valid YAML
Could not start manager: Config file is not valid YAML

flexget -V output:

3.1.71
You are on the latest release.

Running as daemon,btw

2020-09-14 15:41:21 WARNING  check                         Config line 87 is likely missing ':' at the end
2020-09-14 15:41:21 VERBOSE  check                         Pre-checked 89 configuration lines
2020-09-14 15:41:21 CRITICAL manager                       mapping values are not allowed here in "<unicode string>", line 88, column 15: interval: ^

Try defining your schedules as:

schedules:
  - tasks: [ my task ]
    interval:
      days: 3

I did that, and got this as a result of flexget check

2020-09-16 19:10:18 WARNING  check                         Config line 87 is likely missing ':' at the end
2020-09-16 19:10:18 VERBOSE  check                         Pre-checked 89 configuration lines
2020-09-16 19:10:19 CRITICAL manager                       [/tasks/my task/notify] The keys `via`, `title`, `message` are not valid here.
2020-09-16 19:10:19 CRITICAL manager                       [/templates/tv/series/settings/tracking] Got `backfill`, expected: dict
2020-09-16 19:10:19 CRITICAL manager                       [/templates/tv/series/settings/identified_by] Got `ep`, expected: dict
2020-09-16 19:10:19 CRITICAL manager                       [/templates/tv/series/settings/sort_by] The keys `reverse`, `field` are not valid here.
2020-09-16 19:10:19 CRITICAL manager                       Failed to load config file: Did not pass schema validation.
Could not start manager: Did not pass schema validation.

Which is a lot like the errors i’ve seen before, with this config file. Most parts of my file are very similar to (sometimes even just copied from) the cookbook and plugin pages.

I’ve noticed your suggestion has a 2 space indentation after calling the tasks. With a 4 space indentation there I get this output of flexget.check:

2020-09-16 19:07:36 WARNING  check                         Config line 87 is likely missing ':' at the end
2020-09-16 19:07:36 VERBOSE  check                         Pre-checked 89 configuration lines
2020-09-16 19:07:36 CRITICAL manager                       while parsing a block mapping in "<unicode string>", line 87, column 5: - tasks: [ my task ] ^ expected <block end>, but found '<block mapping start>' in "<unicode string>", line 88, column 7: interval: ^

-------------------------------------------------------------------------------
 Malformed configuration file (check messages above). Common reasons:
-------------------------------------------------------------------------------

 o Indentation error
 o Missing : from end of the line
 o Non ASCII characters (use UTF8)
 o If text contains any of :[]{}% characters it must be single-quoted (eg. value{1} should be 'value{1}')

 Reason: expected <block end>, but found '<block mapping start>'

 Check configuration near line 86, column 4
 Check configuration near line 87, column 6

 Fault is almost always in one of these lines or previous ones

2020-09-16 19:07:36 CRITICAL manager                       Failed to load config file: Config file is not valid YAML
Could not start manager: Config file is not valid YAML

I suspect it to be a wrong indentation somewhere, but have checked so many times for accidental tabs and spaces.

Try starting with the very basic series configuration from https://flexget.com/Cookbook/Series/SimpleSeries then add from there, but check the config every time you make a change. This way, you slowly build from an error-free config until you encounter an error - you can then focus on that error.

I tried something similar by commenting out everything that was not necessary in the file, but still got mostly the same errors. So I think you’re right: I will start over, and will post back the results next week.

The basic series configuration with the “download” output works without errors, at least.

So I tried starting over from the cookbook/simpleseries example, and everything was fine until I started adding the template section. So I knew the discover, notify and deluge part were ok.
Trying to work out the errors, more and more errors occured, and began to feel like being in a pit of quicksand. So again I tried starting over using an example using a Trakt.tv list (since so many examples used that plugin specifically). At least now the flexget check runs without errors and flexget —test execute run without errors.

1 Like

The issue with your series config causing errors was that some of your settings were not within the ‘my group’ section of the series settings. It should be like so: